Stuck filter - the filter won't clear away

Maybe I am dense, but I am finding that sometimes the "clear filter " (cf or {Esc}{Esc}) is not restoring the list. I have one long list using numbering list style that seems to be stuck on 9. (i.e., previous 8 items are not showing no matter what I do). Very frustrating.

(update) When I open the offending page on a different computer, the problem goes away, but not on the original computer. I noticed something in the URL:
There is this suffix: “#task_41240730” that I cannot get rid of (when I delete the suffix, it just comes right back) The suffix does not appear when i open the same page on another computer). I really would prefer not to flush the cache of my browser to get rid of it.


I suppose your list is in the “focused” mode - that’s why the task part is there in the URL.
Please try to un-focus, with Shift+Left keyboard shortcut.

Hope this helps,

I ended up clearing the cache and all data for the checkvist domain. A little bit brute force, but it worked, since Checkvist no longer remembered.

I forgot about focus mode. After seeing your reply I went back and tried. Sure enough, that is exactly what happened. I got confused between the filter behavior and the focus behavior. Now i can (un)focus like a pro.

It might be helpful to somehow in the future put a tiny cue or something that lets you know you are in particular modes, like focussed mode. I was going crazy trying to figure out whether I was filtered or what. Thanks, it is an amazing product i hate to complain about it in any way

I’ve noticed that the list title font changes when you’re in focus mode, you might want to try that but yes I agree, it should be made a bit more obvious - just not quite sure how.

We have some UI solution to make focus more prominent, unfortunately, only in design and not in the code. But hope to improve it eventually.